Привет всем читателям wordpressu.ruКак я уже писал в предыдущей статье, вчера мне пришлось понизить версию wordpress, так как были небольшие проблемы с jQuery, из за чего блог некорректно работал, а именно проблемы были в комментариях, то комментарии сдвигались вверх, а контентная часть пропадала куда то под хедер. После чего я начал искать проблему, поочередно отключая плагины, и наконец то мне улыбнулась удача, отключив очередной плагин, отвечающий как раз за вывод кнопок «Ответить» и «Цитировать», я обнаружил что все на блоге встало на свои места. Сначала я пробовал заменить плагин, но результата не было, потом начал пробовать данный плагин с моим шаблоном на разных версиях wordpress, в конечном итоге оказалось так что во всех версиях кроме wordpress 3.5,  мой шаблон и плагин jQuery работают на отлично, после чего вывод был очевиден, надо было понизить версию wordpress. И так если у вас похожая проблема, либо есть какая то несовместимость плагинов, и перед вами встала задача понижения версий wordpress, то ловите простой мануал по понижению версий wordpress.

  1. В самом начале желательно сделать Бэкап вашего блога. Затем переходим на официальный сайт wordpress в раздел «Старые версий wordpress» и скачиваете версию до которой вы хотите понизить. Я скачал версию 3.4.2. 
  2. Затем открываем ftp, подключаемся к нашему блогу, и мы видим в корне две папки wp-admin и wp-includes, выделите обе папки и удалите. Внимание будьте осторожны, не в коем случае не трогайте папку wp-content. 
  3. Теперь распакуйте архив wordpress который вы ранее скачали, выделите все папки и файлы кроме папки wp-content.
  4. Затем скопируйте выделенные файлы и папки с заменой на ваш сервер. 
После того как вы все сделали, зайдите в администраторскую панель ваше блога. Если появится надпись что то типа «Обновить Базу данных«, смело можете соглашаться, wordpress автоматически перестроит таблицы Базы данных для установленной вами версий wordpress.  
На этом можно смело сказать что операция по откату версий завершена. Но напоследок дам один небольшой совет, если вы сильно дорожите своим проектом, то лучше всего сначала потренироваться либо на локальном сервере, либо у себя на хостинге где нибудь на поддомене. Я лично несколько раз проделал операцию понижения версий wordpress сначала на локальном сервере, и только потом когда уже был точно уверен в том что делаю, сделал откат блога.
На этом все, всем желаю удачи! Как всегда по всем вопросам буду рад ответить в комментариях! Буду очень благодарен за ретвит!
P.S По традиций, посмотрите небольшой ролик: Ньюкасл продемонстрировал свою волю к победе






Так же друзья, советую почитать и эти статьи!!!